使用域账号统一保管cisco网络设备,cisco模拟器GNS三和编造机VMware的结合

by admin on 2019年4月14日

微软绵绵Cisco环境:

微软绵绵思科环境:

cisco模拟器GNS三和虚构机VMware的3结合,gns三vmware

微软软Cisco条件:

在Cisco认证的读书中,我们供给选用许多类的模拟器,但这么些模拟器并不能更实在的照猫画虎我们的用户机在采用中所出现的场景。由此,大家借由微软的条件来更诚实地反映我们所搭建的互连网中的1些应用。

微软环境:windows server 2003,在虚拟机(VMware)中我们设置windows
server 2003能够在互连网中展示真实的服务器和主机的某些用到。

思科环境:模拟器GNS3,安装在真机中。

使用域账号统一保管cisco网络设备,cisco模拟器GNS三和编造机VMware的结合。 

目标:在GNS3中得以搭建立模型拟互联网,连接虚拟机中的服务器,约等于网络中的真的服

务器的效能。

福寿齐天步骤:如下图完全环境所示:

home88一必发 1

一)  在GNS3中拖两台3600型号的路由器Rubicon一和Escort二,以及壹朵云。 

二)  右击云点击配置——>C一,然后举办右面包车型客车挑选配置。

home88一必发 2

叁) 
在以太网NIO选项卡下的网络适配器下拉菜单中精选VMware网络适配器VMnet一。

home88一必发 3

四)  点击添加按钮——>再点击出现在上边图框中的适配器——>再点击OK。

home88一必发 4

伍) 
在图中式点心击添加链接——>选取连忙以太链路连接科雷傲二和奥迪Q3一以及卡宴一和云C一,并点击在云C1上发生的网卡适配器建立连接。网络拓扑搭建完了,与早期给出的环境一致,按开机键后展开一多元相关布署。

home88一必发 5

陆)   依照环境给出的供给安插种种路由器。

R2(config)#interface fastEthernet 0/0

R2(config-if)#ip address 12.12.12.2 255.255.255.0

R2(config-if)#no shutdown

R2(config)#interface loopback 0

R2(config-if)#ip address 192.168.1.1 255.255.255.0

R2(config-if)#no shutdown

 

R1(config)#interface fastEthernet 0/0

R1(config-if)#ip address 12.12.12.1 255.255.255.0

R1(config-if)#no shutdown

R1(config)#interface fastEthernet 1/0

R1(config-if)#ip address 172.16.1.1 255.255.255.0

R1(config-if)#no shutdown

 

R2(config)#ip route 172.16.1.0 255.255.255.0 12.12.12.1

R1(config)#ip route 192.168.1.1 255.255.255.255 12.12.12.2

 

七)  在VMware中打开虚拟机win server 200三,实行win server
200三与虚拟机网卡的绑定。首先在win server 2003中选中网络——>setting。

home88一必发 6

捌)  在选项卡中开始展览绑定。

home88一必发 7

9) 
在虚拟机中右击网络邻居——>属性——>右击本地连接——>属性——>常规选项卡中双击采用Internet协议(TCP/IP)进行布局IP地址等。

home88一必发 8

10)  在虚拟机中win server
200叁的运营下的cmd里:ping路由器本田CR-V二的loopback0回环口1九二.168.一.一,简单翻看是不是衔接,注解环境结合成功。

home88一必发 9

 

微软塌塌Cisco条件:
在Cisco证实的学习中,大家供给利用许多类的模拟器,但这么些模拟器并不可能…

①、Cisco设备和微软系统结合的背景:

在Cisco证实的求学中,咱们必要动用许多类的模拟器,但那么些模拟器并不可见更实在的上行下效我们的用户机在使用中所出现的风貌。因而,大家借由微软的条件来更诚实地反映我们所搭建的互连网中的壹些用到。

在Cisco认证的读书中,大家需求运用许多类的模拟器,但这几个模拟器并不可能更实际的一成不变我们的用户机在采纳中所出现的景观。由此,大家借由微软的环境来更诚实地反映我们所搭建的互联网中的1些利用。

店铺里面有肯定数量的客户端,为了贯彻统壹化,在管理当中安顿了域架构,这样可以透过组策略对客户端举行批量化管理,升高了管住的功能。

微软条件:windows server 200三,在虚拟机(VMware)中我们设置windows
server 200三能够在互联网中显示实在的服务器和主机的一部分使用。

微软条件:windows server 2003,在虚拟机(VMware)中大家设置windows
server 200三足以在互连网中反映实在的服务器和主机的局地行使。

使用域账号统一保管cisco网络设备,cisco模拟器GNS三和编造机VMware的结合。1如既往集团里面有一定数额的互联网设施(沟通机,路由器,防火墙等),在远程管理的时候是透过Telnet格局。

Cisco条件:模拟器GNS三,安装在真机中。

Cisco环境:模拟器GNS3,安装在真机中。

在该案例中,希望用户远程管理互连网设施的时候经过到微软的DC(域控制器)上进展身份验证,那样达成了身份验证的单一化,避免维护多套身份验证的架构,大大的简化了协作社IT的军管。

 

 

二、搭建立模型拟条件:

指标:在GNS三中能够搭建立模型拟互联网,连接虚拟机中的服务器,也正是互联网中的真的服

对象:在GNS3中可以搭建立模型拟网络,连接虚拟机中的服务器,也正是互连网中的真的服

home88一必发 10

务器的功能。

务器的功力。

 

完结步骤:如下图完全环境所示:

贯彻步骤:如下图完全环境所示:

如图:搭建的环境为主就为上海教室所示,一台DC域控制器(对网络实行域管理)、一台RADIUS服务器(提供cisco设备认证和微软环境万分整合)、一台交流机、一台路由器、1台PC客户机。*(此试验涉及到cisco模拟器GNS叁和编造机VMware的整合中的环境搭建步骤)*

home88一必发 11

home88一必发 12

壹)  
首先在GNS三模拟器中搭建下图环境:调换机的地方我们用云来取代,依照体系之1的方法把云与大家的虚拟机网卡VMnet1桥接起来。*(具体步骤见cisco模拟器GNS3和虚构机VMware的整合)***

一)  在GNS三中拖两台3600型号的路由器Lacrosse1和Odyssey2,以及1朵云。 

一)  在GNS三中拖两台3600型号的路由器大切诺基1和PAJERO2,以及一朵云。 

home88一必发 13

二)  右击云点击配置——>C一,然后进行右面包车型地铁抉择配置。

贰)  右击云点击配置——>C1,然后举行右面包车型客车选料配置。

 

home88一必发 14

home88一必发 15

一)  
再在VMware中开启三台虚拟机:a)0三Server一;b)03Server2;c)XP一,分别依次模拟a)DC域控制器;b)RADIUS服务器;c)Iris客户机。把三台网卡桥接到VMnet一上,使她们与GNS三中的云连接起来,成功组织出大家要搭建的条件。*(具体步骤见cisco模拟器GNS3和虚拟机VMware的整合)*** 

三) 
在以太网NIO选项卡下的互联网适配器下拉菜单中选拔VMware网络适配器VMnet1。

三) 
在以太网NIO选项卡下的网络适配器下拉菜单中甄选VMware网络适配器VMnet1。

二)   在路由器福特Explorer第11中学配置f0/0接口的IP地址和掩码:

home88一必发 16

home88一必发 17

R1(config)#int f0/0

肆)  点击添加按钮——>再点击出现在底下图框中的适配器——>再点击OK。

四)  点击添加按钮——>再点击出现在底下图框中的适配器——>再点击OK。

R1(config-if)#ip add 10.0.0.11 255.255.255.0

home88一必发 18

home88一必发 19

R1(config-if)#no shutdown 

伍) 
在图中式点心击添加链接——>采用连忙以太链路连接XC90二和福特Explorer一以及ENVISION一和云C一,并点击在云C一上产生的网卡适配器建立连接。网络拓扑搭建完了,与最初给出的条件壹致,按开机键后进行1密密麻麻相关陈设。

五) 
在图中式点心击添加链接——>采纳快捷以太链路连接CR-V2和奥迪Q7一以及Odyssey1和云C一,并点击在云C壹上发出的网卡适配器建立连接。网络拓扑搭建完了,与中期给出的条件壹致,按开机键后开始展览一密密麻麻有关布置。

3)  
在3台虚拟机中布署IP地址:十.0.0.x、子网掩码:25伍.25伍.255.0、私下认可网关:十.0.0.11、首要选用DNS服务器:十.0.0.二,这里DNS服务器正是DC域控制器。

home88一必发 20

home88一必发 21

4)  
假若在展开互动ping命令检验时意识XP1的10.0.0.十0连接ping不通,那么把XP1上的防火墙功能关闭后,再ping。

6)   遵照环境给出的供给安顿各类路由器。

陆)   遵照环境给出的需要配置种种路由器。

3、具体贯彻步骤:

R2(config)#interface fastEthernet 0/0

R2(config)#interface fastEthernet 0/0

第贰步: 
把0三Server一服务器进步为DC域控制器:

R2(config-if)#ip address 12.12.12.2 255.255.255.0

R2(config-if)#ip address 12.12.12.2 255.255.255.0

a)   开始——>运行——>输入dcpromo——>确定

R2(config-if)#no shutdown

R2(config-if)#no shutdown

home88一必发 22

R2(config)#interface loopback 0

R2(config)#interface loopback 0

b)   进入Active Directory安装向导:

R2(config-if)#ip address 192.168.1.1 255.255.255.0

R2(config-if)#ip address 192.168.1.1 255.255.255.0

home88一必发 23

R2(config-if)#no shutdown

R2(config-if)#no shutdown

 

 

 

c)  
一贯点击下一步直到出现下图——>创建八个新域并输入域名:例如ilync.cn——>下一步

R1(config)#interface fastEthernet 0/0

R1(config)#interface fastEthernet 0/0

home88一必发 24

R1(config-if)#ip address 12.12.12.1 255.255.255.0

R1(config-if)#ip address 12.12.12.1 255.255.255.0

d)   一直点击下一步直到出现下图——>输入配置的密码——>下一步

R1(config-if)#no shutdown

R1(config-if)#no shutdown

home88一必发 25

R1(config)#interface fastEthernet 1/0

R1(config)#interface fastEthernet 1/0

e)  
一贯点击下一步——>等待安装向导达成——>点击达成——>点击重新开动电脑——>等待重启

R1(config-if)#ip address 172.16.1.1 255.255.255.0

R1(config-if)#ip address 172.16.1.1 255.255.255.0

 

R1(config-if)#no shutdown

R1(config-if)#no shutdown

第三步: 
在0三Server一上创建用户阿丽丝:

 

 

a)   伊始——>管理工科具——>Active
Directory用户和处理器——>点击“在现阶段容器中创建三个新的团体单位”按钮——>进入新建对象-协会单位对话框

R2(config)#ip route 172.16.1.0 255.255.255.0 12.12.12.1

R2(config)#ip route 172.16.1.0 255.255.255.0 12.12.12.1

home88一必发 26

R1(config)#ip route 192.168.1.1 255.255.255.255 12.12.12.2

R1(config)#ip route 192.168.1.1 255.255.255.255 12.12.12.2

 

 

 

b)   输入要开创的公司单位名称:如sales(销售部)——>显明

七)  在VMware中开拓虚拟机win server 200三,实行win server
200叁与虚拟机网卡的绑定。首先在win server 200三中当选互联网——>setting。

七)  在VMware中开拓虚拟机win server 2003,实行win server
2003与虚拟机网卡的绑定。首先在win server 200三中当选互连网——>setting。

home88一必发 27

home88一必发 28

home88一必发 29

 

八)  在选项卡中举行绑定。

捌)  在选项卡中展开绑定。

c)   在Active
Directory用户和总括机中出现sales——>点击“sales”——>点击“在当下容器中开创八个新用户”按钮——>进入新建对象-用户对话框

home88一必发 30

home88一必发 31

home88一必发 32

玖) 
在虚拟机中右击互连网邻居——>属性——>右击本地连接——>属性——>常规选项卡中双击选取Internet协议(TCP/IP)举行配置IP地址等。

九) 
在虚拟机中右击网络邻居——>属性——>右击本地连接——>属性——>常规选项卡中双击选拔Internet协议(TCP/IP)进行配备IP地址等。

 

home88一必发 33

home88一必发 34

d)   输入要添加的用户名称:如Iris——>下一步

十)  在虚拟机中win server
2003的运作下的cmd里:ping路由器昂Cora二的loopback0回环口192.16捌.壹.1,简单翻看是还是不是衔接,申明环境结合成功。

拾)  在虚拟机中win server
200三的运维下的cmd里:ping路由器途睿欧2的loopback0回环口1九二.16捌.一.一,简单翻看是还是不是衔接,注明环境结合成功。

home88一必发 35

home88一必发 36

home88一必发 37

 

 

 

e)   输入用户登录的密码并且勾选红框中的消息——>下一步——>完毕

home88一必发 38

 

f)   在Active
Directory用户和电脑中现身Iris用户——>点击“在此时此刻容器中创制三个新组”按钮——>输入组名——>明确——>在Active
Directory用户和处理器中冒出贰个创办的telnet新组

home88一必发 39

 

g)  
把阿丽丝用户进入到telnet组内——>双击telnet组——>进入telnet属性对话框——>在成员选项卡下——>添加——>进入选拔用户、联系人或微型总结机对话框——>输入要投入改组的用户名称,如Iris——>点击“地方”按钮——>接纳ilync.cn——>明显——>鲜明

home88一必发 40

 

第三步: 
0叁Server2和XP一参预03Server1创制的域ilync:

a)  
在0三Server2和XP第11中学右击小编的处理器——>属性——>点击电脑名选项卡——>更改——>现身总括机名称改成对话框。 

b)  
在对话框中式点心击域选项——>在框中输入要参与的域名称——>分明——>出现计算机名转移对话框。

home88一必发 41

 

c)  
在对话框中输入到场该域的账户名和密码——>分明——>出现“欢迎加入ilync域”字样对话框——>明确——>出现重复启航空电磁法脑对话框——>明确——>原来的体系本性对话框点击显著——>重新起动电脑——>是

home88一必发 42

home88一必发 43

 

d)  
重新起动电脑后登6到域环境下——>点击“选项”——>登录到:下拉框选取“ILYNC”——>输入用户名——>输入密码——>鲜明

home88一必发 44

home88一必发 45

 

第陆步: 
在0三Server二上添加RADIUS组件服务:

a)  
开端——>控制面板——>添加或删除程序——>添加/删除windows组件(A)——>进入“windows组件向导”对话框——>互连网服务——>详细音讯

home88一必发 46

b)   进入网络服务对话框——>Internet
验证服务——>鲜明——>下一步——>实现

c)  
开首——>管理工科具——>Internet验证服务——>右击Internet验证服务(本地)——>点击“在Active
Directory中注册服务器”——>鲜明——>明确

home88一必发 47

 

d)  
右击RADIUS客户端——>点击新建RADIUS客户端——>现身新建RADIUS客户端对话框

home88一必发 48

 

e)  
在新建RADIUS客户端对话框中输入添加的客户端名称和IP地址,如:大家条件中的Koleos一路由器和它的IP——>下一步

home88一必发 49

 

home88一必发,f)   输入配置AAA认证中的key,也便是登陆福睿斯壹时要输入的密码——>达成

home88一必发 50

 

g)  
右击“远程访问策略”——>新建远程访问策略——>下一步——>选取“设置自定义策略”,并填写策略名——>下一步

home88一必发 51

 

h)   添加——>选择Windows-Group类型——>添加

home88一必发 52

 

i)  
在组对话框中式点心击添加——>进入选用组对话框——>点击“地方”——>选拔ilync.cn——>输入要丰盛的靶子名称——>分明——>鲜明——>下一步

home88一必发 53

 

j)  
在权力中选拔“授予远程访问权限”——>下一步——>编辑配置文件——>身份验证选项卡下——>勾选未加密的身份验证——>分明——>是——>直接关闭现身的“路由和长途访问对话框”——>下一步——>完毕

home88一必发 54

 

第陆步:  在冠道一上配置AAA的身份验证到RADIUS 
Server上:

R1(config)#aaa new-model

R1(config)#radius-server host 10.0.0.3 key 123.com

R1(config)#aaa authentication login telnet group radius

R1(config)#aaa authentication enable default none

R1(config)#line vty 0 4

R1(config-line)#login authentication telnet

 

第五步:  验证主机XP一远程访问卡宴一:

a)   XP一上点击起首——>运营——>输入cmd——>telnet 10.0.0.1一

home88一必发 55

 

b)  
进入telnet下——>输入用户名:(域名\用户名)格局——>输入配置在大切诺基1上的AAA认证的密码

能够观望结果:XP一远程访问Koleos1失败!

home88一必发 56

 

 

c)  
在0三Server二上的事件查看器中查看失败原因:在0叁Server2中式点心击开端——>管理工科具——>事件查看器——>系统——>在右边的事件中发出的告诫条目上双击——>出现风浪性质对话框——>能够看到用户被拒绝访问音信

home88一必发 57

 

d)   消除措施是:在03Server1上安装用户同意访问:在0三Server1中开辟Active
Directory用户和总计机对话框——>双击Alice用户——>出现用户属性对话框——>在拨入选项卡下——>勾选允许访问——>分明

home88一必发 58

 

e)   再一次在XP一上telnet 途乐壹验证远程访问:

可以观察结果:XP一远程访问揽胜极光第11中学标!

home88一必发 59

 

 

f)  
在0三Server二上的事件查看器中查阅:事件条目中没现身警示消息,双击最上边包车型大巴消息查阅——>能够观望用户被授予了访问权

home88一必发 60

 

试验到此形成!!

能够在XP一上对Kuga1拓展安插!!

发表评论

电子邮件地址不会被公开。 必填项已用*标注

网站地图xml地图